Skip to main content

Does my operating system have prerequisites?

Your operating system may require pre-installation setup before installing dbt Core with pip. After downloading and installing any dependencies specific to your development environment, you can proceed with the pip installation of dbt Core.

CentOS

CentOS requires Python and some other dependencies to successfully install and run dbt Core.

To install Python and other dependencies:


sudo yum install redhat-rpm-config gcc libffi-devel \  python-devel openssl-devel

MacOS

The MacOS requires Python 3.7 or higher to successfully install and run dbt Core.

To check the Python version:


python --version

If you need a compatible version, you can download and install Python version 3.7 or higher for MacOS.

If your machine runs on an Apple M1 architecture, we recommend that you install dbt via Rosetta. This is necessary for certain dependencies that are only supported on Intel processors.

Ubuntu/Debian

Ubuntu requires Python and other dependencies to successfully install and run dbt Core.

To install Python and other dependencies:


sudo apt-get install git libpq-dev python-dev python3-pipsudo apt-get remove python-cffisudo pip install --upgrade cffipip install cryptography~=3.4

Windows

Windows requires Python and git to successfully install and run dbt Core.

Install Git for Windows and Python version 3.6 or higher for Windows.